<!DOCTYPE html>
<!--[if lt IE 7]><html lang="en" class="no-js lt-ie9 lt-ie8 lt-ie7" prefix="og: http://ogp.me/ns# fb: http://ogp.me/ns/fb# article: http://ogp.me/ns/article# video: http://ogp.me/ns/video#
profile: http://ogp.me/ns/profile#"><![endif]-->
<!--[if IE 7]><html lang="en" class="no-js lt-ie9 lt-ie8" prefix="og: http://ogp.me/ns# fb: http://ogp.me/ns/fb# article: http://ogp.me/ns/article# video: http://ogp.me/ns/video#
profile: http://ogp.me/ns/profile#"><![endif]-->
<!--[if IE 8]><html lang="en" class="no-js lt-ie9" prefix="og: http://ogp.me/ns# fb: http://ogp.me/ns/fb# article: http://ogp.me/ns/article# video: http://ogp.me/ns/video#
profile: http://ogp.me/ns/profile#"><![endif]-->
<!--[if IE 9]><html lang="en" class="no-js ie9" prefix="og: http://ogp.me/ns# fb: http://ogp.me/ns/fb# article: http://ogp.me/ns/article# video: http://ogp.me/ns/video#
profile: http://ogp.me/ns/profile#" ><![endif]-->
<!--[if gt IE 8]><!--><html class="no-js" lang="en" dir="ltr">
<head>

<script>(function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'gtm.start':
new Date().getTime(),event:'gtm.js'});var f=d.getElementsByTagName(s)[0],
j=d.createElement(s),dl=l!='dataLayer'?'&l='+l:'';j.async=true;j.src=
'https://www.googletagmanager.com/gtm.js?id='+i+dl;f.parentNode.insertBefore(j,f);
})(window,document,'script','dataLayer','GTM-WV2JBLW');</script>

<meta charset="UTF-8">
<link rel="apple-touch-icon" sizes="180x180" href="/resource/crblob/2454148/2dba249e2ea5e42caa40f1ec5344fba8/apple-touch-icon-png-data.png">
<link rel="icon" type="image/png" sizes="32x32" href="/resource/crblob/2454174/e61600403078abb2de6c8c6db0ed129f/favicon-32x32-png-data.png">
<link rel="icon" type="image/png" sizes="16x16" href="/resource/crblob/2454172/e3fe6765fece3b8cd31610d0b968bd97/favicon-16x16-png-data.png">
<link rel="manifest" href="/site.webmanifest">
<link rel="mask-icon" href="/resource/crblob/2454206/13e24a38f5638c3989a015b8e8790d40/safari-pinned-tab-svg-data.svg" color="#5bbad5">
<link rel="shortcut icon" type="image/x-icon" href="/resource/crblob/2454176/fd1af4399745b94c81654246caf617c8/favicon-ico-data.ico">
<meta name="msapplication-TileColor" content="#da532c">
<title>Retracing how Omukama Kabalega escaped the British - NTV Uganda</title>
<meta name="viewport" content="width=device-width, initial-scale=1">
<meta name="robots" content="index, follow" />
<meta name="viewport" content="width=device-width,initial-scale=1.0,user-scalable=0">
<script type="application/ld+json">
{
"@context": "https://schema.org",
"@type": "VideoObject",
"name": "Retracing how Omukama Kabalega escaped the British",
"description": "<p>By November 1893, when Major General Henry Colville arrived in Uganda to protect British interests in the Nile Basin, Omukama Chwa the second Yohana Kabalega had been a thorn in the flesh of the colonialists for a long time due to his growing military might and anti imperialism. His arrival in the Kingdom of Bunyoro-Kitara led to a long period of warfare. After a series of skirmishes and battles, Kabalega retreated north-eastwards to the Budongo forests, and then to Kiryandongo. It was in Karuma Town Council, in present-day Kiryandongo district that Kabalega, with the help of the Paluo or Bachope tribe, made his new tactical headquarters in 1894.<\/p><p><br/><\/p><p>GILLIAN NANTUME details Kabalega’s escape route in Kiryandongo district.<\/p>",
"thumbnailUrl": [
"https://i.ytimg.com/vi/qZaDRwlj9Vk/mqdefault.jpg"
],
"uploadDate": "2022-04-15T18:32:57Z",
"contentUrl": "https://www.ntv.co.ug/ug/news/retracing-how-omukama-kabalega-escaped-the-british-3784186",
"embedUrl": "https://www.youtube.com/embed/qZaDRwlj9Vk"
}
</script>
<script type="application/ld+json">
{
"@context": "http://schema.org",
"@type": "BreadcrumbList",
"itemListElement": [
{
"@type": "ListItem",
"position": 1,
"name": "Home",
"item": "https://www.ntv.co.ug/ug"
}
,
{
"@type": "ListItem",
"position": 2,
"name": "News",
"item": "https://www.ntv.co.ug/ug/news"
}
]
}
</script>
<meta name="description" content="
By November 1893, when Major General Henry Colville arrived in Uganda to protect British interests in the Nile Basin, Omukama Chwa the second Yohana Kabalega had been a thorn in the flesh of the...">
<meta property="og:site_name" content="NTV Uganda" />
<meta property="og:type" content="article" />
<meta property="fb:app_id" content="1998962440280289" />
<meta property="og:title" content="Retracing how Omukama Kabalega escaped the British" />
<meta property="og:url" content="https://www.ntv.co.ug/ug/news/retracing-how-omukama-kabalega-escaped-the-british-3784186" />
<meta property="og:description" content="
By November 1893, when Major General Henry Colville arrived in Uganda to protect British interests in the Nile Basin, Omukama Chwa the second Yohana Kabalega had been a thorn in the flesh of the..." />
<meta property="og:locale" content="en" />
<meta property="og:locale:alternate" content="en_US" />
<meta property="og:article:published_time" content="2022-04-15 21:32:57" />
<meta property="og:image" content="https://i.ytimg.com/vi/qZaDRwlj9Vk/mqdefault.jpg">
<meta name="twitter:card" content="summary_large_image">
<meta name="twitter:site" content="@ntvuganda">
<meta name="twitter:title" content="Retracing how Omukama Kabalega escaped the British">
<meta name="twitter:description" content="
By November 1893, when Major General Henry Colville arrived in Uganda to protect British interests in the Nile Basin, Omukama Chwa the second Yohana Kabalega had been a thorn in the flesh of the...">
<meta name="twitter:image" content="https://i.ytimg.com/vi/qZaDRwlj9Vk/mqdefault.jpg"> <meta charset="utf-8">
<link rel="canonical" href="https://www.ntv.co.ug/ug/news/retracing-how-omukama-kabalega-escaped-the-british-3784186">
<meta name="google-site-verification" content="7PI23eF83yLrptihU4-C11bEaznAQl8mts5BfCS1W2U" />
<script async='async' src='https://www.googletagservices.com/tag/js/gpt.js'></script>
<script>
var googletag = googletag || {};
googletag.cmd = googletag.cmd || [];
</script>
<script>document.documentElement.className = document.documentElement.className.replace(/no-js/g, 'js');</script>
<link href="//cdnjs.cloudflare.com/ajax/libs/font-awesome/4.7.0/css/font-awesome.min.css" rel="stylesheet">
<link rel="stylesheet" href="//secure.widget.cloud.opta.net/v3/css/v3.core.opta-widgets.css">
<link rel="stylesheet" href="//secure.widget.cloud.opta.net/v3/css/v3.football.opta-widgets.css">
<script data-ad-client="ca-pub-0846142691248784" async src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script><link href="/resource/themes/ntv-ug/css/ntv-ug-2454388-102.css" rel="stylesheet">
<script type="text/javascript"> function GaAccountData(webPropertyId, domainName) {
this.webPropertyId = webPropertyId;
this.domainName = domainName;
}
function GaPageviewData(contentId, contentType, navigationPath, pageUrl, authors, pubDate, tags, queryParameter, query, userSegments, disableAdFeaturesPlugin) {
this.contentId = contentId;
this.contentType = contentType;
this.navigationPath = navigationPath;
this.pageUrl = pageUrl;
this.authors = authors;
this.pubDate = pubDate;
this.tags = tags;
this.queryParameter = queryParameter;
this.query = query;
this.userSegments = userSegments;
this.disableAdvertisingFeaturesPlugin = typeof disableAdFeaturesPlugin !== 'undefined' ? disableAdFeaturesPlugin : false;
}
function GaEventData(category, action, name, value) {
this.category = category;
this.action = action;
this.name = name;
this.value = value;
}
function gaTrackPageview(ga, gaAccountData, gaPageviewData, trackerName) {
var t = _gaTrackerPrefix(trackerName);
//set Account
if (trackerName && trackerName.length > 0) {
ga('create', gaAccountData.webPropertyId, gaAccountData.domainName, {'name': trackerName});
} else {
ga('create', gaAccountData.webPropertyId, gaAccountData.domainName);
}
ga(t.concat('set'), 'anonymizeIp', true);
if (!gaPageviewData.disableAdvertisingFeaturesPlugin) {
ga(t.concat('require'), 'displayfeatures');
}
//set custom vars
ga(t.concat('set'), 'dimension1', gaPageviewData.contentId);
ga(t.concat('set'), 'dimension2', gaPageviewData.contentType);
ga(t.concat('set'), 'dimension3', gaPageviewData.navigationPath);
ga(t.concat('set'), 'dimension4', gaPageviewData.userSegments);
ga(t.concat('set'), 'dimension5', gaPageviewData.authors);
ga(t.concat('set'), 'dimension6', gaPageviewData.pubDate);
ga(t.concat('set'), 'dimension7', gaPageviewData.tags);
// if a search was performed on the website, retain the search query
var query = "";
if (gaPageviewData.query && gaPageviewData.queryParameter) {
query = "?" + gaPageviewData.queryParameter + "=" + encodeURIComponent(gaPageviewData.query);
}
//send page view
ga(t.concat('send'), 'pageview', gaPageviewData.pageUrl + query);
}
function gaTrackEvent(ga, gaAccountData, gaPageviewData, gaEventData, trackerName) {
var t = _gaTrackerPrefix(trackerName);
//set Account
if (trackerName && trackerName.length > 0) {
ga('create', gaAccountData.webPropertyId, gaAccountData.domainName, {'name': trackerName});
} else {
ga('create', gaAccountData.webPropertyId, gaAccountData.domainName);
}
ga(t.concat('set'), 'anonymizeIp', true);
if (!gaPageviewData.disableAdvertisingFeaturesPlugin) {
ga(t.concat('require'), 'displayfeatures');
}
//set custom vars
ga(t.concat('set'), 'dimension1', gaPageviewData.contentId);
ga(t.concat('set'), 'dimension2', gaPageviewData.contentType);
ga(t.concat('set'), 'dimension3', gaPageviewData.navigationPath);
ga(t.concat('set'), 'dimension4', gaPageviewData.userSegments);
ga(t.concat('set'), 'dimension5', gaPageviewData.authors);
ga(t.concat('set'), 'dimension6', gaPageviewData.pubDate);
ga(t.concat('set'), 'dimension7', gaPageviewData.tags);
//sent event
ga(t.concat('send'), 'event', gaEventData.category, gaEventData.action, gaEventData.name, gaEventData.value);
}
function _gaTrackerPrefix(trackerName) {
return (trackerName && trackerName.length > 0)
? trackerName.concat('.')
: '';
}
(function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
(i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
})(window,document,'script','//www.google-analytics.com/analytics.js','ga');
var gaAccountData = new GaAccountData("UA-35341027-7", "www.ntv.co.ug");
var gaPageData = new GaPageviewData(
"3784186",
"CMVideo",
"2374418_2374420",
"/ug/news/retracing-how-omukama-kabalega-escaped-the-british-3784186",
"",
"15-04-2022",
"",
false
);
gaTrackPageview(ga, gaAccountData, gaPageData);
</script> <script async src="https://securepubads.g.doubleclick.net/tag/js/gpt.js"></script>
<script async src='/cdn-cgi/challenge-platform/h/b/scripts/invisible.js?ts=1650085200'></script></head><body id="top" style="zoom:1;">

<noscript><iframe src="https://www.googletagmanager.com/ns.html?id=GTM-WV2JBLW"
height="0" width="0" style="display:none;visibility:hidden"></iframe></noscript>

<div class="main_content nav-section">
<div id="main_menu">
<div class="content_wrapper">
<a href="/ug" class="logo">
<img src="/resource/crblob/2454194/612c79ad9565947574392166f327a7bd/ntv-ke-logo-png-data.png" alt="ntv" width="100px">
</a>
<div id="wrap">
<form id="ntv-search" name="searchfrm" action="/service/search/ug/2457728" autocomplete="off" role="search">
<input id="search" name="query" type="text" class="big-search" placeholder="Search" minlength="3" required>
<input type="submit" name="" value="">
</form> </div>
<div class="menu-icon"></div>
<ul class="right">
<li class="full-width">
<a href="/ug/news">News</a>
</li>
<li class="full-width">
<a href="/ug/shows">Shows</a>
</li>
<li class="full-width">
<a href="/ug/features">Features</a>
</li>
<li class="full-width">
<a href="/ug/ntv-live">NTV Live</a>
</li>
<li class="full-width">
<a href="/ug/spark-tv-live">Spark TV Live</a>
</li>
<li class="full-width">
<a href="/ug/commentaries">Commentaries</a>
</li>
</ul>
</div>
</div>
</div>


<div class="main_content">
<div id="breadcrumbs">
<div class="content_wrapper">
<div class="sch-wrapper">
<ul>
<li class="breadcrumb-item" aria-current=""><a href="/ug">NTV UGANDA</a></li>
<span class="icon-angle-right"></span><li class="breadcrumb-item" aria-current=""><a href="/ug/news">NEWS</a></li>
<span class="icon-angle-right"></span> </ul>
</div>
<div id="flag">
<ul>
<li><a href="https://ntv.nation.co.ke" target="_blank"><img src="https://cdn.nation.co.ke/images/tv/kenya.svg" alt="Kenya flag" width="50"></a></li>
<li class="active"><a href="https://www.ntv.co.ug" target="_blank"><img src="https://cdn.nation.co.ke/images/tv/ug.png" alt="Uganda flag" width="50"></a></li>
</ul>
</div>
</div>
</div>
</div>

<div class="main_content">
<div id="banner-area">
<div class="content_wrapper">
<section class="ad noprint"> <span class="">Advertisement</span> <div class="ad">
<script>
var Url_Seg1=window.location.pathname.split( '/' )[1];
if(Url_Seg1==="sports"){ }else{
googletag.cmd.push(function() {
var leaderBoard = googletag.sizeMapping().
addSize([1024, 0], [728, 90]).
addSize([600, 0], [300, 250]).
addSize([800, 0], [728, 90]).
addSize([0, 0], [[320, 50], [320, 100], [300, 75], [300, 100], [300, 50], [300, 250]]).
build();
window.bk_dfp_integration = window.bk_dfp_integration || {}; window.bk_dfp_integration.functions = window.bk_dfp_integration.functions || {}; if(typeof bk_dfp_integration.functions.sendDfp === "function"){ bk_dfp_integration.functions.sendDfp(); }
googletag.defineSlot('/1010816/Z-DN-728x90-ArticleTop',[[320, 50], [320, 100], [300, 75], [300, 100], [300, 50], [728, 90], [300, 250]], 'div-gpt-ad-1489467324804-0').defineSizeMapping(leaderBoard).addService(googletag.pubads());
googletag.pubads().collapseEmptyDivs();
googletag.pubads().setTargeting('url', window.location.pathname.split( '/' )[1]);
googletag.pubads().setTargeting('url2', window.location.pathname.split( '/' )[2]);
googletag.enableServices();
});
}
</script>

<div id='div-gpt-ad-1489467324804-0' style='margin:0 auto;height:auto'>
<script>
if(Url_Seg1==="sports"){ $(".ad").css("background","white"); }else{
googletag.cmd.push(function() { googletag.display('div-gpt-ad-1489467324804-0'); });
}
</script>
</div>
</div> </section> <div class="sliding_banner">
<div class="video-link">
<figure class="content-media content-media--video" id="featured-media">
<iframe src="https://www.youtube.com/embed/qZaDRwlj9Vk" frameborder="0" gesture="media" allow="encrypted-media" allowfullscreen="" id="widget2" class="videoFrame"></iframe> </figure>
<div id="video-statistics">
<div class="date-posted">
11hours ago.
</div>
</div>
</div>
<div class="video-content">
<h3>Retracing how Omukama Kabalega escaped the British</h3>
<div>By November 1893, when Major General Henry Colville arrived in Uganda to protect British interests in the Nile Basin, Omukama Chwa the second Yohana Kabalega had been a thorn in the flesh of the colonialists for a long time due to his growing military might and anti imperialism. His arrival in the Kingdom of Bunyoro-Kitara led to a long period of warfare. After a series of skirmishes and battles, Kabalega retreated north-eastwards to the Budongo forests, and then to Kiryandongo. It was in Karuma Town Council, in present-day Kiryandongo district that Kabalega, with the help of the Paluo or Bachope tribe, made his new tactical headquarters in 1894.
GILLIAN NANTUME details Kabalega’s escape route in Kiryandongo district.</div>
<div id="share-video"><div class="social-networks noprint">
<a href="https://twitter.com/share?text=Retracing how Omukama Kabalega escaped the British&amp;url=https://www.ntv.co.ug/ug/news/retracing-how-omukama-kabalega-escaped-the-british-3784186&amp;via=ntvuganda" target="_blank"><i class="fa fa-twitter" aria-hidden="true"></i></a>
<a href="https://www.facebook.com/sharer.php?u=https://www.ntv.co.ug/ug/news/retracing-how-omukama-kabalega-escaped-the-british-3784186" target="_blank"><i class="fa fa-facebook" aria-hidden="true"></i></a>
<a href="https://www.linkedin.com/shareArticle?mini=true&amp;url=https://www.ntv.co.ug/ug/news/retracing-how-omukama-kabalega-escaped-the-british-3784186" target="_blank"><i class="fa fa-linkedin" aria-hidden="true"></i></a>
<div class="mobileShow">
<a href="https://api.whatsapp.com/send?text=https://www.ntv.co.ug/ug/news/retracing-how-omukama-kabalega-escaped-the-british-3784186" target="_blank"><i class="fa fa-whatsapp" aria-hidden="true"></i></a>
</div>
<a href="javascript:window.print()" target="_blank"><i class="fa fa-print" aria-hidden="true"></i></a>
<a href="/cdn-cgi/l/email-protection#77480402151d1214034a2512030516141e1910571f180057381a021c161a16573c1615161b121016571204141607121357031f125735051e031e041f51161a074c1518130e4a2512030516141e1910571f180057381a021c161a16573c1615161b121016571204141607121357031f125735051e031e041f5a1f030307044d5858000000591903015914185902105802105819120004580512030516141e19105a1f18005a181a021c161a165a1c1615161b1210165a120414160712135a031f125a15051e031e041f5a44404f43464f41" target="_blank"><i class="fa fa-envelope-o" aria-hidden="true"></i></a>
</div></div>
</div>
</div>
</div>
</div>
</div>
<div class="main_content">
<div class="content_wrapper">
<div class="videos-wrapper">
<div id="videos-listings">
<h2>Latest NTV</h2>
<div class="video-gallery-page clearfix">
<ul class="properties">
<li>
<div class="property-wrapper">
<div class="pic-wrapper">
<a href="/ug/news/sports/rugby-sevens-kenyan-university-side-must-beat-hippos-by-7-to-5-points-3784232">
<span class="icon-play2"></span>
<img src="https://i.ytimg.com/vi/4fG0jTAR1xg/mqdefault.jpg" alt="RUGBY SEVENS :Kenyan University side must beat hippos by 7 to 5 points">
</a>
</div>
<div class="desc">
<a href="/ug/news/sports/rugby-sevens-kenyan-university-side-must-beat-hippos-by-7-to-5-points-3784232"><p>RUGBY SEVENS :Kenyan University side must beat hippos by 7 to 5 points</p></a>
</div>
</div>
</li><li>
<div class="property-wrapper">
<div class="pic-wrapper">
<a href="/ug/news/sports/police-clears-2022-fim-central-africa-motocross-tourney-3784228">
<span class="icon-play2"></span>
<img src="https://i.ytimg.com/vi/Lmh8ueFOK5U/mqdefault.jpg" alt="Police clears 2022 FIM Central Africa motocross tourney">
</a>
</div>
<div class="desc">
<a href="/ug/news/sports/police-clears-2022-fim-central-africa-motocross-tourney-3784228"><p>Police clears 2022 FIM Central Africa motocross tourney</p></a>
</div>
</div>
</li><li>
<div class="property-wrapper">
<div class="pic-wrapper">
<a href="/ug/news/sports/bul-fc-beat-gadafi-fc-by-2-0-in-league-3784226">
<span class="icon-play2"></span>
<img src="https://i.ytimg.com/vi/1Y7bzLd99Ss/mqdefault.jpg" alt="Bul FC beat Gadafi FC by 2-0 in league">
</a>
</div>
<div class="desc">
<a href="/ug/news/sports/bul-fc-beat-gadafi-fc-by-2-0-in-league-3784226"><p>Bul FC beat Gadafi FC by 2-0 in league</p></a>
</div>
</div>
</li><li>
<div class="property-wrapper">
<div class="pic-wrapper">
<a href="/ug/news/sports/cranes-beat-buganda-fc-by-2-1-in-friendly-3784224">
<span class="icon-play2"></span>
<img src="https://i.ytimg.com/vi/vvCIdcmwo_c/mqdefault.jpg" alt="Cranes beat Buganda FC by 2-1 in friendly">
</a>
</div>
<div class="desc">
<a href="/ug/news/sports/cranes-beat-buganda-fc-by-2-1-in-friendly-3784224"><p>Cranes beat Buganda FC by 2-1 in friendly</p></a>
</div>
</div>
</li><li>
<div class="property-wrapper">
<div class="pic-wrapper">
<a href="/ug/news/rising-prices-gov-t-insists-there-will-be-no-price-controls-3784208">
<span class="icon-play2"></span>
<img src="https://i.ytimg.com/vi/qrA2edGBI7k/mqdefault.jpg" alt="RISING PRICES :Gov’t insists there will be no price controls">
</a>
</div>
<div class="desc">
<a href="/ug/news/rising-prices-gov-t-insists-there-will-be-no-price-controls-3784208"><p>RISING PRICES :Gov’t insists there will be no price controls</p></a>
</div>
</div>
</li><li>
<div class="property-wrapper">
<div class="pic-wrapper">
<a href="/ug/news/11-in-the-ring-to-replace-jacob-oulanyah-as-mp-3784204">
<span class="icon-play2"></span>
<img src="https://i.ytimg.com/vi/e2mQMABvH8E/mqdefault.jpg" alt="11 in the ring to replace Jacob Oulanyah as MP">
</a>
</div>
<div class="desc">
<a href="/ug/news/11-in-the-ring-to-replace-jacob-oulanyah-as-mp-3784204"><p>11 in the ring to replace Jacob Oulanyah as MP</p></a>
</div>
</div>
</li><li>
<div class="property-wrapper">
<div class="pic-wrapper">
<a href="/ug/news/fish-maw-licenses-gov-t-denies-preferential-treatment-for-fishermen-3784200">
<span class="icon-play2"></span>
<img src="https://i.ytimg.com/vi/habW32J7xo0/mqdefault.jpg" alt="FISH MAW LICENSES: Gov’t denies preferential treatment for fishermen">
</a>
</div>
<div class="desc">
<a href="/ug/news/fish-maw-licenses-gov-t-denies-preferential-treatment-for-fishermen-3784200"><p>FISH MAW LICENSES: Gov’t denies preferential treatment for fishermen</p></a>
</div>
</div>
</li><li>
<div class="property-wrapper">
<div class="pic-wrapper">
<a href="/ug/news/uganda-railways-report-report-recommends-punishment-for-privatization-unit-3784198">
<span class="icon-play2"></span>
<img src="https://i.ytimg.com/vi/BfCzWyeqExc/mqdefault.jpg" alt="UGANDA RAILWAYS’ REPORT :Report recommends punishment for privatization unit">
</a>
</div>
<div class="desc">
<a href="/ug/news/uganda-railways-report-report-recommends-punishment-for-privatization-unit-3784198"><p>UGANDA RAILWAYS’ REPORT :Report recommends punishment for privatization unit</p></a>
</div>
</div>
</li><li>
<div class="property-wrapper">
<div class="pic-wrapper">
<a href="/ug/news/lop-mpuuga-says-mps-sswanyana-and-ssegirinya-need-urgent-medical-care-3784196">
<span class="icon-play2"></span>
<img src="https://i.ytimg.com/vi/13kuqJLjnc8/mqdefault.jpg" alt="LOP Mpuuga says MPs Sswanyana and Ssegirinya need urgent medical care">
</a>
</div>
<div class="desc">
<a href="/ug/news/lop-mpuuga-says-mps-sswanyana-and-ssegirinya-need-urgent-medical-care-3784196"><p>LOP Mpuuga says MPs Sswanyana and Ssegirinya need urgent medical care</p></a>
</div>
</div>
</li><li>
<div class="property-wrapper">
<div class="pic-wrapper">
<a href="/ug/news/insecurity-question-karamoja-elders-call-for-compulsory-education-for-youths-3784192">
<span class="icon-play2"></span>
<img src="https://i.ytimg.com/vi/ELj40S0ACYE/mqdefault.jpg" alt="INSECURITY QUESTION: Karamoja elders call for compulsory education for youths">
</a>
</div>
<div class="desc">
<a href="/ug/news/insecurity-question-karamoja-elders-call-for-compulsory-education-for-youths-3784192"><p>INSECURITY QUESTION: Karamoja elders call for compulsory education for youths</p></a>
</div>
</div>
</li><li>
<div class="property-wrapper">
<div class="pic-wrapper">
<a href="/ug/news/three-bystanders-injured-as-mpigi-bus-overturns-3784190">
<span class="icon-play2"></span>
<img src="https://i.ytimg.com/vi/cVc14ZdelyA/mqdefault.jpg" alt="Three bystanders injured as Mpigi bus overturns">
</a>
</div>
<div class="desc">
<a href="/ug/news/three-bystanders-injured-as-mpigi-bus-overturns-3784190"><p>Three bystanders injured as Mpigi bus overturns</p></a>
</div>
</div>
</li><li>
<div class="property-wrapper">
<div class="pic-wrapper">
<a href="/ug/news/how-the-faithful-commemorated-good-friday-3784188">
<span class="icon-play2"></span>
<img src="https://i.ytimg.com/vi/tPbYkp8D2jc/mqdefault.jpg" alt="How the faithful commemorated Good Friday">
</a>
</div>
<div class="desc">
<a href="/ug/news/how-the-faithful-commemorated-good-friday-3784188"><p>How the faithful commemorated Good Friday</p></a>
</div>
</div>
</li><li>
<div class="property-wrapper">
<div class="pic-wrapper">
<a href="/ug/news/akawungeezi/omukama-kabalega-ebimu-ku-bifo-weyasimba-amakanda-okulwana-n-abazungu-3784154">
<span class="icon-play2"></span>
<img src="https://i.ytimg.com/vi/PFwe6123IKY/mqdefault.jpg" alt="OMUKAMA KABALEGA:Ebimu ku bifo weyasimba amakanda okulwana n’abazungu">
</a>
</div>
<div class="desc">
<a href="/ug/news/akawungeezi/omukama-kabalega-ebimu-ku-bifo-weyasimba-amakanda-okulwana-n-abazungu-3784154"><p>OMUKAMA KABALEGA:Ebimu ku bifo weyasimba amakanda okulwana n’abazungu</p></a>
</div>
</div>
</li><li>
<div class="property-wrapper">
<div class="pic-wrapper">
<a href="/ug/news/akawungeezi/empaka-za-ddigi-poliisi-erambudde-ekifo-we-zigenda-okuba-e-garuga-3784098">
<span class="icon-play2"></span>
<img src="https://i.ytimg.com/vi/Y-eANPdCSsk/mqdefault.jpg" alt="EMPAKA ZA DDIGI:Poliisi erambudde ekifo we zigenda okuba e Garuga">
</a>
</div>
<div class="desc">
<a href="/ug/news/akawungeezi/empaka-za-ddigi-poliisi-erambudde-ekifo-we-zigenda-okuba-e-garuga-3784098"><p>EMPAKA ZA DDIGI:Poliisi erambudde ekifo we zigenda okuba e Garuga</p></a>
</div>
</div>
</li><li>
<div class="property-wrapper">
<div class="pic-wrapper">
<a href="/ug/news/akawungeezi/zungulu-biki-ebyaddirira-nga-yuda-akwasiddwa-akasimbi-k-okulyamu-yesu-olukwe--3784090">
<span class="icon-play2"></span>
<img src="https://i.ytimg.com/vi/o3RLOM2Lxmg/mqdefault.jpg" alt="ZUNGULU: Biki ebyaddirira nga Yuda akwasiddwa akasimbi k&#39;okulyamu Yesu olukwe?">
</a>
</div>
<div class="desc">
<a href="/ug/news/akawungeezi/zungulu-biki-ebyaddirira-nga-yuda-akwasiddwa-akasimbi-k-okulyamu-yesu-olukwe--3784090"><p>ZUNGULU: Biki ebyaddirira nga Yuda akwasiddwa akasimbi k&#39;okulyamu Yesu olukwe?</p></a>
</div>
</div>
</li> </ul>
</div>
<section class="ad noprint">
<span class="">Advertisement</span>
<div class="ad">
<script data-cfasync="false" src="/cdn-cgi/scripts/5c5dd728/cloudflare-static/email-decode.min.js"></script><script>
window.googletag = window.googletag || {cmd: []};
googletag.cmd.push(function() {
var mobileResize = googletag.sizeMapping().
addSize([1024, 0], [728, 90]).
addSize([600, 0], [300, 250]).
addSize([800, 0], [728, 90]).
addSize([0, 0], [300, 250]).
build();
googletag.defineSlot('/1010816/Z-Dn-728x90-newsarticle', [[300, 250], [728, 90]], 'div-gpt-ad-1591700957341-0').defineSizeMapping(mobileResize).addService(googletag.pubads());
googletag.pubads().enableSingleRequest();
googletag.pubads().collapseEmptyDivs();
googletag.enableServices();
});
</script>

<div id='div-gpt-ad-1591700957341-0'>
<script>
googletag.cmd.push(function() { googletag.display('div-gpt-ad-1591700957341-0'); });
</script>
</div> </div>
</section>
</div>
</div>
<div class="sidebar">
<script>
function sendDfp() {
window.bk_dfp_integration = window.bk_dfp_integration || {};
window.bk_dfp_integration.functions = window.bk_dfp_integration.functions || {};
if (typeof bk_dfp_integration.functions.sendDfp === "function") {
bk_dfp_integration.functions.sendDfp();
}
}
googletag.cmd.push(function () {
var mobileResize = googletag.sizeMapping().
addSize([1024, 0], [[970, 90], [728, 90]]).
addSize([600, 0], [300, 250]).
addSize([800, 0], [728, 90]).
addSize([0, 0], [[300, 250],[320, 50], [300, 100], [300, 50],[320,100]]).
build();
sendDfp();
googletag.defineSlot('/1010816/NTV-300x250-Home-1', [[300, 250], [300, 600]], 'div-gpt-ad-1600938858957-0').addService(googletag.pubads());
googletag.pubads().collapseEmptyDivs();
googletag.pubads().setTargeting('url', window.location.pathname.split( '/' )[1]);
googletag.pubads().setTargeting('url2', window.location.pathname.split( '/' )[2]);
googletag.enableServices();
});
</script>
<div class="ad">

<div id='div-gpt-ad-1600938858957-0'>
<script>
googletag.cmd.push(function() { googletag.display('div-gpt-ad-1600938858957-0'); });
</script>
</div>
</div><div class="tab-header">
<div class="tab">
<span class="icon most-read-icon"></span>Latest Monitor News</div>
</div>
<div class="tab-body">
<li class="most-popular-item">
<a href="https://www.monitor.co.ug/uganda/news/national/drug-pollution-detected-in-uganda-water-bodies-3784424">
<span class="most-number">1</span>
<span class="most-headline"><span>National</span> Drug pollution detected in Uganda water bodies</span>
</a>
</li>
<li class="most-popular-item">
<a href="https://www.monitor.co.ug/uganda/news/south-africa-flood-toll-nears-400-as-rescuers-search-for-missing-3784416">
<span class="most-number">2</span>
<span class="most-headline"><span>News</span> South Africa flood toll nears 400 as rescuers search for missing</span>
</a>
</li>
<li class="most-popular-item">
<a href="https://www.monitor.co.ug/uganda/news/national/rwanda-excludes-refugees-from-neighbouring-states-in-uk-deal-3784420">
<span class="most-number">3</span>
<span class="most-headline"><span>National</span> Rwanda excludes East African refugees from UK deal</span>
</a>
</li>
<li class="most-popular-item">
<a href="https://www.monitor.co.ug/uganda/news/national/man-kills-wife-attempts-to-bury-her-in-house-police--3784162">
<span class="most-number">4</span>
<span class="most-headline"><span>National</span> Man kills wife, attempts to bury her in house - police </span>
</a>
</li>
<li class="most-popular-item">
<a href="https://www.monitor.co.ug/uganda/news/national/school-director-arrested-for-defiling-12-year-old-girl-3783768">
<span class="most-number">5</span>
<span class="most-headline"><span>National</span> School director arrested for defiling 12-year-old girl</span>
</a>
</li>
</div><script>
function sendDfp() {
window.bk_dfp_integration = window.bk_dfp_integration || {};
window.bk_dfp_integration.functions = window.bk_dfp_integration.functions || {};
if (typeof bk_dfp_integration.functions.sendDfp === "function") {
bk_dfp_integration.functions.sendDfp();
}
}
googletag.cmd.push(function () {
var mobileResize = googletag.sizeMapping().
addSize([1024, 0], [[970, 90], [728, 90]]).
addSize([600, 0], [300, 250]).
addSize([800, 0], [728, 90]).
addSize([0, 0], [[300, 250],[320, 50], [300, 100], [300, 50],[320,100]]).
build();
sendDfp();
googletag.defineSlot('/1010816/NTV-300x250-Home-2', [[300, 250], [300, 600]], 'div-gpt-ad-1600938931269-0').addService(googletag.pubads());
googletag.pubads().collapseEmptyDivs();
googletag.pubads().setTargeting('url', window.location.pathname.split( '/' )[1]);
googletag.pubads().setTargeting('url2', window.location.pathname.split( '/' )[2]);
googletag.enableServices();
});
</script>
<div class="ad sticky-article">

<div id='div-gpt-ad-1600938931269-0'>
<script>
googletag.cmd.push(function() { googletag.display('div-gpt-ad-1600938931269-0'); });
</script>
</div>
</div> </div>
</div>
</div>
</div>
<footer class="wrapper page-footer" id="page-footer">
<div class="menu-holder menu-holder-footer noprint">
<nav class="menu-vertical footer-section" role="navigation">
<header>
<a href="/ug/news" title="News">
<h3 class="footer-section-heading">News</h3>
</a>
</header>
<a href="/ug/news/national" title="National">National</a>
<a href="/ug/news/akawungeezi" title="Akawungeezi">Akawungeezi</a>
<a href="/ug/news/business" title="Business">Business</a>
<a href="/ug/news/international" title="International">International</a>
<a href="/ug/news/sports" title="Sports">Sports</a>
<a href="/ug/news/science-tech" title="Science &amp; Tech">Science &amp; Tech</a>
<a href="/ug/news/sparktv-news" title="SparkTV News">SparkTV News</a>
<a href="/ug/news/poscasts" title="Poscasts">Poscasts</a>
</nav>
<nav class="menu-vertical footer-section" role="navigation">
<header>
<a href="/ug/shows" title="Shows">
<h3 class="footer-section-heading">Shows</h3>
</a>
</header>
<a href="/ug/shows/fourth-estate" title="Fourth Estate">Fourth Estate</a>
<a href="/ug/shows/panorama" title="Panorama">Panorama</a>
<a href="/ug/shows/seed-of-gold" title="Seed of Gold">Seed of Gold</a>
<a href="/ug/shows/tuwaye" title="Tuwaye">Tuwaye</a>
<a href="/ug/shows/pwjk" title="PWJK">PWJK</a>
<a href="/ug/shows/men" title="Men">Men</a>
<a href="/ug/shows/on-the-spot" title="On the Spot">On the Spot</a>
<a href="/ug/shows/mwasuze-mutya" title="Mwasuze Mutya">Mwasuze Mutya</a>
</nav>
<nav class="menu-vertical footer-section" role="navigation">
<header>
<a href="/ug/features" title="Features">
<h3 class="footer-section-heading">Features</h3>
</a>
</header>
</nav>
<nav class="menu-vertical footer-section" role="navigation">
<header>
<a href="/ug/ntv-live" title="NTV Live">
<h3 class="footer-section-heading">NTV Live</h3>
</a>
</header>
</nav>
<nav class="menu-vertical footer-section" role="navigation">
<header>
<a href="/ug/spark-tv-live" title="Spark TV Live">
<h3 class="footer-section-heading">Spark TV Live</h3>
</a>
</header>
</nav>
<nav class="menu-vertical footer-section" role="navigation">
<header>
<a href="/ug/commentaries" title="Commentaries">
<h3 class="footer-section-heading">Commentaries</h3>
</a>
</header>
</nav>
</div>
<footer id="dnFooter">
<div class="dnFooter-row noprint">
<div class="dnFooter-col-sm-3">
<h5></h5>
<h5></h5>
<a href="/ug">
<img src="/resource/crblob/2454140/612c79ad9565947574392166f327a7bd/amp-logo-png-data.png" alt="NTV Uganda" class="logo">
</a>
</div>
<div class="dnFooter-col-sm-2">
<h5>Apps</h5>
<ul>
<li><a href="https://play.google.com/store/apps/developer?id=Nation%20Media%20Group&amp;amp;hl=en&amp;amp;pcampaignid=MKT-Other-global-all-co-prtnr-py-PartBadge-Mar2515-1" target="_blank"><img alt="Play Store" src="/resource/crblob/2454178/50e4f00026394f5a265aaf340a5d0a57/google-play-badge-png-data.png"></a></li><br>
<li><a href="https://itunes.apple.com/us/developer/nation-media-group-ltd/id771736086" target="_blank"><img src="/resource/crblob/2454146/9ee20d40415c85b17474ec89f15aabcd/appstoreicon-svg-data.svg" alt="App Store" class="logo"></a></li>
</ul>
</div>
<div class="dnFooter-col-sm-2">
<h5>Information</h5>
<ul>
<li><a href="https://nation.africa/kenya/empower" target="_blank" title="Empower Africa">Empower Africa</a></li>
<li><a href="https://www.monitor.co.ug/uganda/contact-us-1934576" target="_blank" title="Contact Us">Contact Us</a></li>
<li><a href="https://nation.africa/kenya/frequently-asked-questions-303716" target="_blank" title="Frequently asked questions">Frequently asked questions</a></li>
<li><a href="https://nation.africa/kenya/nmg-privacy-policy-303724" target="_blank" title="NMG Privacy Policy">NMG Privacy Policy</a></li>
<li><a href="https://nation.africa/kenya/terms-and-conditions" target="_blank" title="Terms and Conditions of Use">Terms and Conditions of Use</a></li>
<li><a href="https://nation.africa/kenya/our-blog-rules-549010" target="_blank" title="Our Blog Rules">Our Blog Rules</a></li>
</ul>
</div>
<div class="dnFooter-col-sm-2">
<h5>NMG Sites</h5>
<ul>
<li><a href="http://www.businessdailyafrica.com/" target="_blank" title="Business Daily">Business Daily</a></li>
<li><a href="https://nation.africa" target="_blank" title="Nation.Africa">Nation.Africa</a></li>
<li><a href="http://www.monitor.co.ug/" target="_blank" title="Daily Monitor">Daily Monitor</a></li>
<li><a href="http://www.thecitizen.co.tz/" target="_blank" title="The Citizen">The Citizen</a></li>
<li><a href="http://www.theeastafrican.co.ke/" target="_blank" title="The Eastafrican">The Eastafrican</a></li>
<li><a href="http://www.nationmedia.com/" target="_blank" title="Nation Media Group">Nation Media Group</a></li>
</ul>
</div>
<div class="dnFooter-col-sm-3">
<h5>Follow us</h5>
<div class="social-networks">
<a href="https://twitter.com/NTVUganda" target="_blank">
<i class="fa fa-twitter" aria-hidden="true"></i>
</a>
<a href="https://www.facebook.com/NTVUganda" target="_blank">
<i class="fa fa-facebook" aria-hidden="true"></i>
</a>
<a href="https://www.instagram.com/ntvuganda/" target="_blank">
<i class="fa fa-instagram" aria-hidden="true"></i>
</a>
<a href="https://www.youtube.com/user/ntvuganda" target="_blank">
<i class="fa fa-youtube" aria-hidden="true"></i>
</a>
<h1 style="font-size: 0px; margin: 0px;">NTV</h1>
</div>
</div>
</footer>
</footer><noscript class="cm-javascript">
Please enable JavaScript to use this website.
</noscript>
<script type='text/javascript' src='//www.youtube.com/iframe_api'></script>
<script type='text/javascript'>
(function() {
var _sf_async_config = window._sf_async_config = (window._sf_async_config || {});
/** CONFIGURATION START **/
_sf_async_config.uid = 63208;
_sf_async_config.domain = 'ntv.co.ug';
_sf_async_config.flickerControl = false;
_sf_async_config.useCanonical = true;
_sf_async_config.useCanonicalDomain = true;
_sf_async_config.sections = 'News';
/** CONFIGURATION END **/
function loadChartbeat() {
var e = document.createElement('script');
var n = document.getElementsByTagName('script')[0];
e.type = 'text/javascript';
e.async = true;
e.src = '//static.chartbeat.com/js/chartbeat_video.js';
n.parentNode.insertBefore(e, n);
}
/** TELL CHARTBEAT TO AUTODETECT YOUTUBE VIDEOS **/
var _cbv = window._cbv || (window._cbv = []);
_cbv.push(['autoDetectYouTubeIframes']);
loadChartbeat();
})();
</script>
<script async src="//static.chartbeat.com/js/chartbeat_mab.js"></script><script src="/resource/themes/ntv-ug/js/commons-2454382-1.js"></script><script src="/resource/themes/ntv-ug/js/ntv-ug-2454384-6.js"></script><script>
window.googletag = window.googletag || {cmd: []};
googletag.cmd.push(function() {
googletag.defineOutOfPageSlot('/1010816/NTVU-outofpage', 'div-gpt-ad-1643030219109-0').addService(googletag.pubads());
googletag.pubads().enableSingleRequest();
googletag.enableServices();
});
</script>

<div id='div-gpt-ad-1643030219109-0'>
<script>
googletag.cmd.push(function() { googletag.display('div-gpt-ad-1643030219109-0'); });
</script>
</div><script type="text/javascript">(function(){window['__CF$cv$params']={r:'6fcaa2edca7b5a16',m:'JukDqMZ7bmPHrFhMV5xbXNx0TkNeyW7DgjLgJ9dt_6A-1650088153-0-ASJkTYU3Nv/I35XiJceeqDa3Uv7PCYsyQqe2dv+giY5tLkhR05wYgbhVBs9kDHQVLS8Vy9gMYtuuY2wrQDZ+ZMlFNbj9ZlTYHeLwwnPFTjD5jy8ziTdwh/OywlISpDGHhUTBJFxnOArslHgQJ3NpxiZ4tVKDTyz8K+dKYhhwQWL+KD3i/Dlrjb2AAd08GWJ+yoqmCkxSoIiU4XrLx5XagL4=',s:[0xbc6cc853f3,0x8a2a47df1e],u:'/cdn-cgi/challenge-platform/h/b'}})();</script></body></html>
