<!DOCTYPE html>
<!--[if lt IE 7]><html lang="en" class="no-js lt-ie9 lt-ie8 lt-ie7" prefix="og: http://ogp.me/ns# fb: http://ogp.me/ns/fb# article: http://ogp.me/ns/article# video: http://ogp.me/ns/video#
profile: http://ogp.me/ns/profile#"><![endif]-->
<!--[if IE 7]><html lang="en" class="no-js lt-ie9 lt-ie8" prefix="og: http://ogp.me/ns# fb: http://ogp.me/ns/fb# article: http://ogp.me/ns/article# video: http://ogp.me/ns/video#
profile: http://ogp.me/ns/profile#"><![endif]-->
<!--[if IE 8]><html lang="en" class="no-js lt-ie9" prefix="og: http://ogp.me/ns# fb: http://ogp.me/ns/fb# article: http://ogp.me/ns/article# video: http://ogp.me/ns/video#
profile: http://ogp.me/ns/profile#"><![endif]-->
<!--[if IE 9]><html lang="en" class="no-js ie9" prefix="og: http://ogp.me/ns# fb: http://ogp.me/ns/fb# article: http://ogp.me/ns/article# video: http://ogp.me/ns/video#
profile: http://ogp.me/ns/profile#" ><![endif]-->
<!--[if gt IE 8]><!--><html class="no-js" lang="en" dir="ltr">
<head>

<script>(function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'gtm.start':
new Date().getTime(),event:'gtm.js'});var f=d.getElementsByTagName(s)[0],
j=d.createElement(s),dl=l!='dataLayer'?'&l='+l:'';j.async=true;j.src=
'https://www.googletagmanager.com/gtm.js?id='+i+dl;f.parentNode.insertBefore(j,f);
})(window,document,'script','dataLayer','GTM-WV2JBLW');</script>

<meta charset="UTF-8">
<link rel="apple-touch-icon" sizes="180x180" href="/resource/crblob/2454148/2dba249e2ea5e42caa40f1ec5344fba8/apple-touch-icon-png-data.png">
<link rel="icon" type="image/png" sizes="32x32" href="/resource/crblob/2454174/e61600403078abb2de6c8c6db0ed129f/favicon-32x32-png-data.png">
<link rel="icon" type="image/png" sizes="16x16" href="/resource/crblob/2454172/e3fe6765fece3b8cd31610d0b968bd97/favicon-16x16-png-data.png">
<link rel="manifest" href="/site.webmanifest">
<link rel="mask-icon" href="/resource/crblob/2454206/13e24a38f5638c3989a015b8e8790d40/safari-pinned-tab-svg-data.svg" color="#5bbad5">
<link rel="shortcut icon" type="image/x-icon" href="/resource/crblob/2454176/fd1af4399745b94c81654246caf617c8/favicon-ico-data.ico">
<meta name="msapplication-TileColor" content="#da532c">
<title>Who does the NRM government work for? - NTV Uganda</title>
<meta name="viewport" content="width=device-width, initial-scale=1">
<meta name="robots" content="index, follow" />
<meta name="viewport" content="width=device-width,initial-scale=1.0,user-scalable=0">
<script type="application/ld+json">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</script>
<script type="application/ld+json">
{
"@context": "http://schema.org",
"@type": "BreadcrumbList",
"itemListElement": [
{
"@type": "ListItem",
"position": 1,
"name": "Home",
"item": "https://www.ntv.co.ug/ug"
}
,
{
"@type": "ListItem",
"position": 2,
"name": "Commentaries",
"item": "https://www.ntv.co.ug/ug/commentaries"
}
]
}
</script>
<meta name="description" content="
On the 26th day of January this year, the NRM government celebrated 36 years in power. It is rather unfortunate that what was being celebrated is not reflected in the lives of many Ugandans...">
<meta property="og:site_name" content="NTV Uganda" />
<meta property="og:type" content="article" />
<meta property="fb:app_id" content="1998962440280289" />
<meta property="og:title" content="Who does the NRM government work for?" />
<meta property="og:url" content="https://www.ntv.co.ug/ug/commentaries/who-does-the-nrm-government-work-for--3719018" />
<meta property="og:description" content="
On the 26th day of January this year, the NRM government celebrated 36 years in power. It is rather unfortunate that what was being celebrated is not reflected in the lives of many Ugandans..." />
<meta property="og:locale" content="en" />
<meta property="og:locale:alternate" content="en_US" />
<meta property="og:article:published_time" content="2022-02-16 16:16:14" />
<meta property="og:image" content="https://www.ntv.co.ug/resource/blob/3719010/e8604f70d908444697f93db74badc463/museveni-okoler-opio-lo-amanu-data.jpg">
<meta name="twitter:card" content="summary_large_image">
<meta name="twitter:site" content="@ntvuganda">
<meta name="twitter:title" content="Who does the NRM government work for?">
<meta name="twitter:description" content="
On the 26th day of January this year, the NRM government celebrated 36 years in power. It is rather unfortunate that what was being celebrated is not reflected in the lives of many Ugandans...">
<meta name="twitter:image" content="https://www.ntv.co.ug/resource/blob/3719010/e8604f70d908444697f93db74badc463/museveni-okoler-opio-lo-amanu-data.jpg"> <meta charset="utf-8">
<link rel="canonical" href="https://www.ntv.co.ug/ug/commentaries/who-does-the-nrm-government-work-for--3719018">
<meta name="google-site-verification" content="7PI23eF83yLrptihU4-C11bEaznAQl8mts5BfCS1W2U" />
<script async='async' src='https://www.googletagservices.com/tag/js/gpt.js'></script>
<script>
var googletag = googletag || {};
googletag.cmd = googletag.cmd || [];
</script>
<script>document.documentElement.className = document.documentElement.className.replace(/no-js/g, 'js');</script>
<link href="//cdnjs.cloudflare.com/ajax/libs/font-awesome/4.7.0/css/font-awesome.min.css" rel="stylesheet">
<link rel="stylesheet" href="//secure.widget.cloud.opta.net/v3/css/v3.core.opta-widgets.css">
<link rel="stylesheet" href="//secure.widget.cloud.opta.net/v3/css/v3.football.opta-widgets.css">
<link rel="amphtml" href="https://www.ntv.co.ug/ug/commentaries/who-does-the-nrm-government-work-for--3719018?view=htmlamp">
<script type="text/javascript">
window._taboola = window._taboola || [];
_taboola.push({article:'auto'});
!function (e, f, u, i) {
if (!document.getElementById(i)){
e.async = 1;
e.src = u;
e.id = i;
f.parentNode.insertBefore(e, f);
}
}(document.createElement('script'),
document.getElementsByTagName('script')[0],
'//cdn.taboola.com/libtrc/nationmediagroup-dailynation/loader.js',
'tb_loader_script');
if(window.performance && typeof window.performance.mark == 'function')
{window.performance.mark('tbl_ic');}
</script>
<script data-ad-client="ca-pub-0846142691248784" async src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script><link href="/resource/themes/ntv-ug/css/ntv-ug-2454388-95.css" rel="stylesheet">
<script type="text/javascript"> function GaAccountData(webPropertyId, domainName) {
this.webPropertyId = webPropertyId;
this.domainName = domainName;
}
function GaPageviewData(contentId, contentType, navigationPath, pageUrl, authors, pubDate, tags, queryParameter, query, userSegments, disableAdFeaturesPlugin) {
this.contentId = contentId;
this.contentType = contentType;
this.navigationPath = navigationPath;
this.pageUrl = pageUrl;
this.authors = authors;
this.pubDate = pubDate;
this.tags = tags;
this.queryParameter = queryParameter;
this.query = query;
this.userSegments = userSegments;
this.disableAdvertisingFeaturesPlugin = typeof disableAdFeaturesPlugin !== 'undefined' ? disableAdFeaturesPlugin : false;
}
function GaEventData(category, action, name, value) {
this.category = category;
this.action = action;
this.name = name;
this.value = value;
}
function gaTrackPageview(ga, gaAccountData, gaPageviewData, trackerName) {
var t = _gaTrackerPrefix(trackerName);
//set Account
if (trackerName && trackerName.length > 0) {
ga('create', gaAccountData.webPropertyId, gaAccountData.domainName, {'name': trackerName});
} else {
ga('create', gaAccountData.webPropertyId, gaAccountData.domainName);
}
ga(t.concat('set'), 'anonymizeIp', true);
if (!gaPageviewData.disableAdvertisingFeaturesPlugin) {
ga(t.concat('require'), 'displayfeatures');
}
//set custom vars
ga(t.concat('set'), 'dimension1', gaPageviewData.contentId);
ga(t.concat('set'), 'dimension2', gaPageviewData.contentType);
ga(t.concat('set'), 'dimension3', gaPageviewData.navigationPath);
ga(t.concat('set'), 'dimension4', gaPageviewData.userSegments);
ga(t.concat('set'), 'dimension5', gaPageviewData.authors);
ga(t.concat('set'), 'dimension6', gaPageviewData.pubDate);
ga(t.concat('set'), 'dimension7', gaPageviewData.tags);
// if a search was performed on the website, retain the search query
var query = "";
if (gaPageviewData.query && gaPageviewData.queryParameter) {
query = "?" + gaPageviewData.queryParameter + "=" + encodeURIComponent(gaPageviewData.query);
}
//send page view
ga(t.concat('send'), 'pageview', gaPageviewData.pageUrl + query);
}
function gaTrackEvent(ga, gaAccountData, gaPageviewData, gaEventData, trackerName) {
var t = _gaTrackerPrefix(trackerName);
//set Account
if (trackerName && trackerName.length > 0) {
ga('create', gaAccountData.webPropertyId, gaAccountData.domainName, {'name': trackerName});
} else {
ga('create', gaAccountData.webPropertyId, gaAccountData.domainName);
}
ga(t.concat('set'), 'anonymizeIp', true);
if (!gaPageviewData.disableAdvertisingFeaturesPlugin) {
ga(t.concat('require'), 'displayfeatures');
}
//set custom vars
ga(t.concat('set'), 'dimension1', gaPageviewData.contentId);
ga(t.concat('set'), 'dimension2', gaPageviewData.contentType);
ga(t.concat('set'), 'dimension3', gaPageviewData.navigationPath);
ga(t.concat('set'), 'dimension4', gaPageviewData.userSegments);
ga(t.concat('set'), 'dimension5', gaPageviewData.authors);
ga(t.concat('set'), 'dimension6', gaPageviewData.pubDate);
ga(t.concat('set'), 'dimension7', gaPageviewData.tags);
//sent event
ga(t.concat('send'), 'event', gaEventData.category, gaEventData.action, gaEventData.name, gaEventData.value);
}
function _gaTrackerPrefix(trackerName) {
return (trackerName && trackerName.length > 0)
? trackerName.concat('.')
: '';
}
(function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
(i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
})(window,document,'script','//www.google-analytics.com/analytics.js','ga');
var gaAccountData = new GaAccountData("UA-35341027-7", "www.ntv.co.ug");
var gaPageData = new GaPageviewData(
"3719018",
"CMArticle",
"2374418_2374432",
"/ug/commentaries/who-does-the-nrm-government-work-for--3719018",
"Guest Writer",
"16-02-2022",
"",
false
);
gaTrackPageview(ga, gaAccountData, gaPageData);
</script> <script async src="https://securepubads.g.doubleclick.net/tag/js/gpt.js"></script>
<script async src='/cdn-cgi/challenge-platform/h/b/scripts/invisible.js'></script></head><body id="top" style="zoom:1;">

<noscript><iframe src="https://www.googletagmanager.com/ns.html?id=GTM-WV2JBLW"
height="0" width="0" style="display:none;visibility:hidden"></iframe></noscript>

<div class="main_content nav-section">
<div id="main_menu">
<div class="content_wrapper">
<a href="/ug" class="logo">
<img src="/resource/crblob/2454194/612c79ad9565947574392166f327a7bd/ntv-ke-logo-png-data.png" alt="ntv" width="100px">
</a>
<div id="wrap">
<form id="ntv-search" name="searchfrm" action="/service/search/ug/2457728" autocomplete="off" role="search">
<input id="search" name="query" type="text" class="big-search" placeholder="Search" minlength="3" required>
<input type="submit" name="" value="">
</form> </div>
<div class="menu-icon"></div>
<ul class="right">
<li class="full-width">
<a href="/ug/news">News</a>
</li>
<li class="full-width">
<a href="/ug/shows">Shows</a>
</li>
<li class="full-width">
<a href="/ug/features">Features</a>
</li>
<li class="full-width">
<a href="/ug/ntv-live">NTV Live</a>
</li>
<li class="full-width">
<a href="/ug/spark-tv-live">Spark TV Live</a>
</li>
<li class="full-width">
<a href="/ug/commentaries">Commentaries</a>
</li>
<li class="full-width">
<a href="/ug/schedule">Schedule</a>
</li>
</ul>
</div>
</div>
</div>


<div class="main_content">
<div id="breadcrumbs">
<div class="content_wrapper">
<div class="sch-wrapper">
<ul>
<li class="breadcrumb-item" aria-current=""><a href="/ug">NTV UGANDA</a></li>
<span class="icon-angle-right"></span><li class="breadcrumb-item" aria-current=""><a href="/ug/commentaries">COMMENTARIES</a></li>
<span class="icon-angle-right"></span> </ul>
</div>
<div id="flag">
<ul>
<li><a href="https://ntv.nation.co.ke" target="_blank"><img src="https://cdn.nation.co.ke/images/tv/kenya.svg" alt="Kenya flag" width="50"></a></li>
<li class="active"><a href="https://www.ntv.co.ug" target="_blank"><img src="https://cdn.nation.co.ke/images/tv/ug.png" alt="Uganda flag" width="50"></a></li>
</ul>
</div>
</div>
</div>
</div>

<div class="container">
<div class="row">
<article class="main column">
<section class="ad noprint"> <span class="">Advertisement</span> <div class="ad">
<script>
var Url_Seg1=window.location.pathname.split( '/' )[1];
if(Url_Seg1==="sports"){ }else{
googletag.cmd.push(function() {
var leaderBoard = googletag.sizeMapping().
addSize([1024, 0], [728, 90]).
addSize([600, 0], [300, 250]).
addSize([800, 0], [728, 90]).
addSize([0, 0], [[320, 50], [320, 100], [300, 75], [300, 100], [300, 50], [300, 250]]).
build();
window.bk_dfp_integration = window.bk_dfp_integration || {}; window.bk_dfp_integration.functions = window.bk_dfp_integration.functions || {}; if(typeof bk_dfp_integration.functions.sendDfp === "function"){ bk_dfp_integration.functions.sendDfp(); }
googletag.defineSlot('/1010816/Z-DN-728x90-ArticleTop',[[320, 50], [320, 100], [300, 75], [300, 100], [300, 50], [728, 90], [300, 250]], 'div-gpt-ad-1489467324804-0').defineSizeMapping(leaderBoard).addService(googletag.pubads());
googletag.pubads().collapseEmptyDivs();
googletag.pubads().setTargeting('url', window.location.pathname.split( '/' )[1]);
googletag.pubads().setTargeting('url2', window.location.pathname.split( '/' )[2]);
googletag.enableServices();
});
}
</script>

<div id='div-gpt-ad-1489467324804-0' style='margin:0 auto;height:auto'>
<script>
if(Url_Seg1==="sports"){ $(".ad").css("background","white"); }else{
googletag.cmd.push(function() { googletag.display('div-gpt-ad-1489467324804-0'); });
}
</script>
</div>
</div> </section> <header>
<h2>Who does the NRM government work for?</h2>
<p class="summary"></p>
<h6>Wednesday February 16 2022</h6>
<div class="social-networks noprint">
<a href="https://twitter.com/share?text=Who does the NRM government work for?&amp;url=https://www.ntv.co.ug/ug/commentaries/who-does-the-nrm-government-work-for--3719018&amp;via=ntvuganda" target="_blank"><i class="fa fa-twitter" aria-hidden="true"></i></a>
<a href="https://www.facebook.com/sharer.php?u=https://www.ntv.co.ug/ug/commentaries/who-does-the-nrm-government-work-for--3719018" target="_blank"><i class="fa fa-facebook" aria-hidden="true"></i></a>
<a href="https://www.linkedin.com/shareArticle?mini=true&amp;url=https://www.ntv.co.ug/ug/commentaries/who-does-the-nrm-government-work-for--3719018" target="_blank"><i class="fa fa-linkedin" aria-hidden="true"></i></a>
<div class="mobileShow">
<a href="https://api.whatsapp.com/send?text=https://www.ntv.co.ug/ug/commentaries/who-does-the-nrm-government-work-for--3719018" target="_blank"><i class="fa fa-whatsapp" aria-hidden="true"></i></a>
</div>
<a href="javascript:window.print()" target="_blank"><i class="fa fa-print" aria-hidden="true"></i></a>
<a href="/cdn-cgi/l/email-protection#90afe3e5f2faf5f3e4adc7f8ffb0f4fff5e3b0e4f8f5b0dec2ddb0f7ffe6f5e2fefdf5fee4b0e7ffe2fbb0f6ffe2afb6f1fde0abf2fff4e9adc7f8ffb0f4fff5e3b0e4f8f5b0dec2ddb0f7ffe6f5e2fefdf5fee4b0e7ffe2fbb0f6ffe2afbdf8e4e4e0e3aabfbfe7e7e7befee4e6bef3ffbee5f7bfe5f7bff3fffdfdf5fee4f1e2f9f5e3bfe7f8ffbdf4fff5e3bde4f8f5bdfee2fdbdf7ffe6f5e2fefdf5fee4bde7ffe2fbbdf6ffe2bdbda3a7a1a9a0a1a8" target="_blank"><i class="fa fa-envelope-o" aria-hidden="true"></i></a>
</div> <div>
<div class="storyTopPic">
<img src="/resource/blob/3719010/e8604f70d908444697f93db74badc463/museveni-okoler-opio-lo-amanu-data.jpg" alt="Museveni, Okoler Opio Lo Amanu" class="cm-media cm-media--loading " title="">
</div>
<p id="photo_article_caption">President Yoweri Kaguta Museveni (Inserted is Okoler Opio Lo Amanu, the write of this piece)</p> </div>
</header>
<article class="article">
<section class="article-sidebar">
<section class="ad noprint">
<span class="">Advertisement</span>
<div class="ad">
<script data-cfasync="false" src="/cdn-cgi/scripts/5c5dd728/cloudflare-static/email-decode.min.js"></script><script>
window.googletag = window.googletag || {cmd: []};
googletag.cmd.push(function() {
googletag.defineSlot('/1010816/Z-DN-300x250-News-inContent-3', [[336, 280], [300, 250]], 'div-gpt-ad-1591698519235-0').addService(googletag.pubads());
googletag.pubads().enableSingleRequest();
googletag.pubads().collapseEmptyDivs();
googletag.enableServices();
});
</script>

<div id='div-gpt-ad-1591698519235-0'>
<script>
googletag.cmd.push(function() { googletag.display('div-gpt-ad-1591698519235-0'); });
</script>
</div> </div>
</section>
</section>
<section class="body-copy">
<section class="author noprint">
<figure class="left">
</figure>
<strong>By Guest Writer</strong>
<div><a href="https://www.monitor.co.ug/uganda/guest-writer-1936032"><span class="author-profile">More by this Author</span></a></div>
</section>
<br />
<p>On the 26th day of January this year, the NRM government celebrated 36 years in power. It is rather unfortunate that what was being celebrated is not reflected in the lives of many Ugandans including a big section of those that attended the function at Kololo Independence grounds.</p><p>Several ordinary Ugandans are failing to pay Boda Boda riders to take their children to school due to the high fees asked. These were a result of the skyrocketing fuel prices, which do not only alter the transport fares but are directly proportional to the prices of services and goods. That is, the higher the fuel prices, the more expensive the goods and services become. For instance, the sugar that was selling at Ugx. 2800 is now being sold at UGX 3,700, a bar of white star soap that was previously worth at UGX 3,000 is now at UGX 6,000, a litre of cooking oil is now UGX 5,500 and a big size loaf of bread is UGX 6,000 up from UGX 3,200.</p><p>The high prices of these commodities shoot affordability far away from the ambit of many people, thus rendering their accessibility useless.</p><p>Indeed, a big number of Ugandans have painfully given up on using these commodities.  But, can you imagine a homestead without soap in times when our survival as humans greatly depends on washing hands with soap or detergents?</p><p>Noteworthy, all this is happening under a clear recollection of the government's assurance to Ugandans that the fuel prices will drop in two weeks after clearing the cargo trucks at the border points. The carbon trucks were cleared months ago but the situation hasn't changed.</p><p>After capturing power in 1986 President Museveni promised Ugandans an independent, integrated and self-reliant economy. Is the economy independent? Of course, it cannot be considering that a big percentage of our budget is funded by external development partners and with a tax base of only one million.</p> <section class="ad noprint">
<span class="">Advertisement</span>
<div class="ad">
<script>
window.googletag = window.googletag || {cmd: []};
googletag.cmd.push(function() {
var leaderBoard = googletag.sizeMapping().
addSize([1024, 0], [728, 90]).
addSize([600, 0], [300, 250]).
addSize([800, 0], [728, 90]).
addSize([0, 0], [[320, 50], [300, 75], [300, 100], [300, 50], [300, 250]]).
build();
googletag.defineSlot('/1010816/Z-DN-728x90-inArticleRelated', [[300, 50], [320, 480], [300, 100], [320, 50], [300, 250], [300, 75], [728, 90]], 'div-gpt-ad-1592285737951-0').defineSizeMapping(leaderBoard).addService(googletag.pubads());
googletag.pubads().enableSingleRequest();
googletag.pubads().collapseEmptyDivs();
googletag.enableServices();
});
</script>

<div id='div-gpt-ad-1592285737951-0'>
<script>
googletag.cmd.push(function() { googletag.display('div-gpt-ad-1592285737951-0'); });
</script>
</div> </div>
</section>
<p>Is it integrated? How can that be when some neighbours deny some of our products their market because of poor quality grades arising from poor handling of such goods. How can it be when our neighbours close their borders to us for over three years?</p><p>Is it self reliant? No, because we have a public debt of USD 18.9billion which is bigger than the country's national budget of USD 12.7 billion. Therefore, it is not in doubt that thirty-six years down the road we seem to have not moved an inch. I do not think that Ugandans are living this promise when many cannot afford basic commodities.</p><p>I want to believe that the biggest mistake done by the NRM government is surrendering the administration of key sectors namely; transport, health and education to private entrepreneurs. These entrepreneurs' major objective is to make a profit at whatever cost. Ipso facto, the government becomes powerless at a time when Ugandans are being cheated by these money "sharks". This fact is alive in contemporary Uganda. We have seen the Prime Minister offer nothing but lamentations in times when Ugandans were exorbitantly charged hundreds of millions by private health care facilities to treat COVID 19.</p><p>Recently during the high fuel prices debacle, the leader of government business in the 11th parliament lamented again. This time around, she was advising Ugandans to shun petrol stations that sold fuel expensively as if to suggest that there were those selling fuel at lower prices.  My friend Kiyimba Shafick would say, in a Luganda dialect, that " Ki Uganda kinyuma' which means that "Uganda is interesting".</p><p>These and many more incidences usher in the big question of who does the NRM government work for?</p><p>Your guess is as good as mine. The governments that work for the people will always protect the interests of citizens from those of business owners by taking charge of the prices of services and goods in key sectors. Uganda should benchmark countries like Nigeria in developing a legal framework to control prices of services and goods in the economy. The government of Nigeria enacted the Price Control Act with a fully-fledged board to prevail over business owners attempting to cheat the citizenry.</p><p>The education sector is another mess, the school fees and a list of requirements are determined by the school owners as the government looks on. Oftentimes, the schools ask for more than what is needed. For instance, why ask for five dozen of books, eight reams of paper, two bags of cement, development fee paid on a termly basis and yet the school fees asked from parents are humongous.</p><p>While advising schools to allow pregnant and breastfeeding teenagers in class, some owners rejected the proposal and the government couldn't do a thing because it is without power in respect of directing events in key sectors. What sort of government is this that doesn't give priority to what affects the people but rather comes in full force to subdue political opponents?</p><p>Lastly, I believe strongly that there is one remedy to the current crisis of high prices that are bedevilling ordinary Ugandans. Let the government enact a strong legal framework regulating the prices of commodities and services especially in key sectors, the law should be equipped with sharp sanctions against those that violate it, this won't be new in Uganda we have had such laws before and the population was protected.</p><p><br /></p><p><strong><em>The guest writer is Okoler Opio Lo Amanu. He is a Food Scientist and the spokesperson for the Democratic Party (DP).</em></strong></p><p><br /></p> </section>
</article>
<script type="text/javascript" src="https://theconversation.com/javascripts/lib/content_tracker_hook.js" id="theconversation_tracker_hook" data-counter="https://counter.theconversation.com/content/UNDEFINED/count?distributor=republish-lightbox-advanced" async="async"></script> <section class="ad noprint">
<span class="">Advertisement</span>
<div class="ad">
<script>
window.googletag = window.googletag || {cmd: []};
googletag.cmd.push(function() {
var mobileResize = googletag.sizeMapping().
addSize([1024, 0], [728, 90]).
addSize([600, 0], [300, 250]).
addSize([800, 0], [728, 90]).
addSize([0, 0], [300, 250]).
build();
googletag.defineSlot('/1010816/Z-Dn-728x90-newsarticle', [[300, 250], [728, 90]], 'div-gpt-ad-1591700957341-0').defineSizeMapping(mobileResize).addService(googletag.pubads());
googletag.pubads().enableSingleRequest();
googletag.pubads().collapseEmptyDivs();
googletag.enableServices();
});
</script>

<div id='div-gpt-ad-1591700957341-0'>
<script>
googletag.cmd.push(function() { googletag.display('div-gpt-ad-1591700957341-0'); });
</script>
</div> </div>
</section>
<script async src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<ins class="adsbygoogle" style="display:block" data-ad-format="autorelaxed" data-ad-client="ca-pub-0846142691248784" data-ad-slot="2445181500"></ins>
<script>
(adsbygoogle = window.adsbygoogle || []).push({});
</script>
</article>
<aside class="aside column noprint">
<div class="row">
<div class="sidebar-item">
<script>
window.googletag = window.googletag || {cmd: []};
googletag.cmd.push(function() {
googletag.defineSlot('/1010816/BD-300x250-Content1', [300, 250], 'div-gpt-ad-1600346004654-0').addService(googletag.pubads());
googletag.pubads().enableSingleRequest();
googletag.pubads().collapseEmptyDivs();
googletag.enableServices();
});
</script>

<div id='div-gpt-ad-1600346004654-0' class='ad'>
<script>
googletag.cmd.push(function() { googletag.display('div-gpt-ad-1600346004654-0'); });
</script>
</div> </div>
<div class="sidebar-item">
<script async src="https://securepubads.g.doubleclick.net/tag/js/gpt.js"></script>
<script>
window.googletag = window.googletag || {cmd: []};
googletag.cmd.push(function() {
googletag.defineSlot('/1010816/BD-300x250-InContent-Left', [300, 250], 'div-gpt-ad-1600346402178-0').addService(googletag.pubads());
googletag.pubads().enableSingleRequest();
googletag.pubads().collapseEmptyDivs();
googletag.enableServices();
});
</script>

<div id='div-gpt-ad-1600346402178-0' class='ad'>
<script>
googletag.cmd.push(function() { googletag.display('div-gpt-ad-1600346402178-0'); });
</script>
</div> </div>
</div>
</aside>
</div>
</div>
<script type="text/javascript">
/* CONFIGURATION START */
var _ain = {
id: "1714",
postid: "new-3719018",
maincontent: "h2, #photo_article_caption, section.summary, section.body-copy",
title: "Who does the NRM government work for?",
pubdate: "2022-02-16 04:16:14",
authors: "Guest Writer",
sections: "Commentaries",
tags: "",
comments: "",
access_level: "free",
reader_type: "anonymous"
};
/* CONFIGURATION END */
(function(d,s){var sf=d.createElement(s);sf.type='text/javascript';sf.async=!0;sf.src=(('https:'==d.location.protocol)?'https://d7d3cf2e81d293050033-3dfc0615b0fd7b49143049256703bfce.ssl.cf1.rackcdn.com':'http://t.contentinsights.com')+'/stf.js';var t=d.getElementsByTagName(s)[0];t.parentNode.insertBefore(sf,t)})(document,'script')
</script>
<script>
dataLayer = [{
'site': 'ntv.co.ug',
'section': 'Commentaries',
'pageTitle': 'Who does the NRM government work for?',
'author': 'Guest Writer',
'keywords': ''
}];
</script>
<footer class="wrapper page-footer" id="page-footer">
<div class="menu-holder menu-holder-footer noprint">
<nav class="menu-vertical footer-section" role="navigation">
<header>
<a href="/ug/news" title="News">
<h3 class="footer-section-heading">News</h3>
</a>
</header>
<a href="/ug/news/national" title="National">National</a>
<a href="/ug/news/akawungeezi" title="Akawungeezi">Akawungeezi</a>
<a href="/ug/news/business" title="Business">Business</a>
<a href="/ug/news/international" title="International">International</a>
<a href="/ug/news/sports" title="Sports">Sports</a>
<a href="/ug/news/science-tech" title="Science &amp; Tech">Science &amp; Tech</a>
<a href="/ug/news/sparktv-news" title="SparkTV News">SparkTV News</a>
<a href="/ug/news/poscasts" title="Poscasts">Poscasts</a>
</nav>
<nav class="menu-vertical footer-section" role="navigation">
<header>
<a href="/ug/shows" title="Shows">
<h3 class="footer-section-heading">Shows</h3>
</a>
</header>
<a href="/ug/shows/fourth-estate" title="Fourth Estate">Fourth Estate</a>
<a href="/ug/shows/panorama" title="Panorama">Panorama</a>
<a href="/ug/shows/seed-of-gold" title="Seed of Gold">Seed of Gold</a>
<a href="/ug/shows/tuwaye" title="Tuwaye">Tuwaye</a>
<a href="/ug/shows/pwjk" title="PWJK">PWJK</a>
<a href="/ug/shows/men" title="Men">Men</a>
<a href="/ug/shows/on-the-spot" title="On the Spot">On the Spot</a>
<a href="/ug/shows/mwasuze-mutya" title="Mwasuze Mutya">Mwasuze Mutya</a>
</nav>
<nav class="menu-vertical footer-section" role="navigation">
<header>
<a href="/ug/features" title="Features">
<h3 class="footer-section-heading">Features</h3>
</a>
</header>
</nav>
<nav class="menu-vertical footer-section" role="navigation">
<header>
<a href="/ug/ntv-live" title="NTV Live">
<h3 class="footer-section-heading">NTV Live</h3>
</a>
</header>
</nav>
<nav class="menu-vertical footer-section" role="navigation">
<header>
<a href="/ug/spark-tv-live" title="Spark TV Live">
<h3 class="footer-section-heading">Spark TV Live</h3>
</a>
</header>
</nav>
<nav class="menu-vertical footer-section" role="navigation">
<header>
<a href="/ug/commentaries" title="Commentaries">
<h3 class="footer-section-heading">Commentaries</h3>
</a>
</header>
</nav>
<nav class="menu-vertical footer-section" role="navigation">
<header>
<a href="/ug/schedule" title="Schedule">
<h3 class="footer-section-heading">Schedule</h3>
</a>
</header>
</nav>
</div>
<footer id="dnFooter">
<div class="dnFooter-row noprint">
<div class="dnFooter-col-sm-3">
<h5></h5>
<h5></h5>
<a href="/ug">
<img src="/resource/crblob/2454140/612c79ad9565947574392166f327a7bd/amp-logo-png-data.png" alt="NTV Uganda" class="logo">
</a>
</div>
<div class="dnFooter-col-sm-2">
<h5>Apps</h5>
<ul>
<li><a href="https://play.google.com/store/apps/developer?id=Nation%20Media%20Group&amp;amp;hl=en&amp;amp;pcampaignid=MKT-Other-global-all-co-prtnr-py-PartBadge-Mar2515-1" target="_blank"><img alt="Play Store" src="/resource/crblob/2454178/50e4f00026394f5a265aaf340a5d0a57/google-play-badge-png-data.png"></a></li><br>
<li><a href="https://itunes.apple.com/us/developer/nation-media-group-ltd/id771736086" target="_blank"><img src="/resource/crblob/2454146/9ee20d40415c85b17474ec89f15aabcd/appstoreicon-svg-data.svg" alt="App Store" class="logo"></a></li>
</ul>
</div>
<div class="dnFooter-col-sm-2">
<h5>Information</h5>
<ul>
<li><a href="https://nation.africa/kenya/empower" target="_blank" title="Empower Africa">Empower Africa</a></li>
<li><a href="https://www.monitor.co.ug/uganda/contact-us-1934576" target="_blank" title="Contact Us">Contact Us</a></li>
<li><a href="https://nation.africa/kenya/frequently-asked-questions-303716" target="_blank" title="Frequently asked questions">Frequently asked questions</a></li>
<li><a href="https://nation.africa/kenya/nmg-privacy-policy-303724" target="_blank" title="NMG Privacy Policy">NMG Privacy Policy</a></li>
<li><a href="https://nation.africa/kenya/terms-and-conditions" target="_blank" title="Terms and Conditions of Use">Terms and Conditions of Use</a></li>
<li><a href="https://nation.africa/kenya/our-blog-rules-549010" target="_blank" title="Our Blog Rules">Our Blog Rules</a></li>
</ul>
</div>
<div class="dnFooter-col-sm-2">
<h5>NMG Sites</h5>
<ul>
<li><a href="http://www.businessdailyafrica.com/" target="_blank" title="Business Daily">Business Daily</a></li>
<li><a href="https://nation.africa" target="_blank" title="Nation.Africa">Nation.Africa</a></li>
<li><a href="http://www.monitor.co.ug/" target="_blank" title="Daily Monitor">Daily Monitor</a></li>
<li><a href="http://www.thecitizen.co.tz/" target="_blank" title="The Citizen">The Citizen</a></li>
<li><a href="http://www.theeastafrican.co.ke/" target="_blank" title="The Eastafrican">The Eastafrican</a></li>
<li><a href="http://www.nationmedia.com/" target="_blank" title="Nation Media Group">Nation Media Group</a></li>
</ul>
</div>
<div class="dnFooter-col-sm-3">
<h5>Follow us</h5>
<div class="social-networks">
<a href="https://twitter.com/NTVUganda" target="_blank">
<i class="fa fa-twitter" aria-hidden="true"></i>
</a>
<a href="https://www.facebook.com/NTVUganda" target="_blank">
<i class="fa fa-facebook" aria-hidden="true"></i>
</a>
<a href="https://www.instagram.com/ntvuganda/" target="_blank">
<i class="fa fa-instagram" aria-hidden="true"></i>
</a>
<a href="https://www.youtube.com/user/ntvuganda" target="_blank">
<i class="fa fa-youtube" aria-hidden="true"></i>
</a>
<h1 style="font-size: 0px; margin: 0px;">NTV</h1>
</div>
</div>
</footer>
</footer><noscript class="cm-javascript">
Please enable JavaScript to use this website.
</noscript>
<script type='text/javascript' src='//www.youtube.com/iframe_api'></script>
<script type='text/javascript'>
(function() {
var _sf_async_config = window._sf_async_config = (window._sf_async_config || {});
/** CONFIGURATION START **/
_sf_async_config.uid = 63208;
_sf_async_config.domain = 'ntv.co.ug';
_sf_async_config.flickerControl = false;
_sf_async_config.useCanonical = true;
_sf_async_config.useCanonicalDomain = true;
_sf_async_config.sections = 'Commentaries';
_sf_async_config.authors ='Guest Writer';
/** CONFIGURATION END **/
function loadChartbeat() {
var e = document.createElement('script');
var n = document.getElementsByTagName('script')[0];
e.type = 'text/javascript';
e.async = true;
e.src = '//static.chartbeat.com/js/chartbeat_video.js';
n.parentNode.insertBefore(e, n);
}
/** TELL CHARTBEAT TO AUTODETECT YOUTUBE VIDEOS **/
var _cbv = window._cbv || (window._cbv = []);
_cbv.push(['autoDetectYouTubeIframes']);
loadChartbeat();
})();
</script>
<script async src="//static.chartbeat.com/js/chartbeat_mab.js"></script> <script type="text/javascript">
window._taboola = window._taboola || [];
_taboola.push({flush: true});
</script>
<script src="/resource/themes/ntv-ug/js/commons-2454382-1.js"></script><script src="/resource/themes/ntv-ug/js/ntv-ug-2454384-6.js"></script><script>
window.googletag = window.googletag || {cmd: []};
googletag.cmd.push(function() {
googletag.defineOutOfPageSlot('/1010816/NTVU-outofpage', 'div-gpt-ad-1643030219109-0').addService(googletag.pubads());
googletag.pubads().enableSingleRequest();
googletag.enableServices();
});
</script>

<div id='div-gpt-ad-1643030219109-0'>
<script>
googletag.cmd.push(function() { googletag.display('div-gpt-ad-1643030219109-0'); });
</script>
</div><script type="text/javascript">(function(){window['__CF$cv$params']={r:'6de865ff1c6a57dc',m:'BtiC37V5w38ey80KNNFgwj34CcQTcy2r7ul4E6gkDXY-1645031521-0-Aa+jISAWOsE3A8QJXVVbkP1827rxQtdD7rjdBWL22FFngygpIMNvZNAe5oYv1HFFcbWwnTY2Va9n7DXV/WPg+QU71GeZ1R5VjbjGVqtcCjnr9L+Pf+hEA/xNydXgOdAXkNgvmkEKCRR/xfx5/6VPvvsqurnBBot8nntFwLn/vX908rJaCz5GixOeNwEYCugFUA==',s:[0x1ce9f00b98,0xcce606c1b0],u:'/cdn-cgi/challenge-platform/h/b'}})();</script></body></html>
